Why is there a GUI rendering error related to a smart section?


I am experiencing an error with a smart section that was working just a week ago. This smart section exists across various environments, but is now causing an error in the development environment. I have experimented with the following:

  • Removing the smart section causes record to show properly.
  • Association and reverse association are both set properly.
  • Removing all fields from the smart section causes the record to show properly, but adding any one field results in an error again.
  • I can move the smart section to another tab and the rest of the record shows properly, until I click on the tab with the smart section.
  • I have already tried object migrating the business object and form from an environment that works.

In the server log, this is error that shows:

440 ERROR [com.tririga.platform.error.ErrorHandler](WebContainer : 16) Report handled exception: com.tririga.platform.gui.rendering.GuiRenderingException: Could not render Gui Component: GuiTabMetadataImpl[Name=triGeneral,ID=14,GUI=GuiMetadataImpl[Name=tdbREProjectAuction,ID=10048479]] for record: SmartObjectImpl[ID=SmartObjectId[ID=47510356,Business Object ID=10002876],Business Object=BoImpl[name=triREProject,id=10002876,module=ModuleImpl[name=triProject,id=19]]][MID-3549400938]...

[Admin: This post is related to the 05.25.17 post about a GUI rendering issue. To see other related posts, use the Smart Section tag.]

Continue reading

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s